Estamos encantados de anunciar una nueva sección en la documentación de InterSystems, que hace más fácil actualizar InterSystems IRIS®, InterSystems IRIS® for Health™ y HealthShare® Health Connect. La Lista de Comprobación de Actualizaciones (en https://docs.intersystems.com/upgrade) muestra todo lo que hay que tener en cuenta - y solo lo que hay que tener en cuenta – en una actualización entre dos versiones cualquiera. La lista recopila todo el contenido de nuestro "Historial de Incompatibilidades" y añade unos filtros muy útiles, categorías de nivel superior y la posibilidad de exportar la lista como un archivo CSV, para que se pueda usar como una verdadera lista de comprobación mientras se trabaja en una actualización.

Os pongo un ejemplo inspirador:

1 1
0 31

InterSystems ha decidido detener el desarrollo de SAM (Alerta y Monitorización del Sistema) y etiquetarlo como deprecated (depreciado, obsoleto, en desuso) desde hoy. InterSystems continuará dando soporte a los clientes existentes que utilicen la tecnología, pero no lo recomienda para nuevas implementaciones.

Hemos descubierto que la mayoría de los clientes que están interesados en el tipo de monitorización ofrecida por SAM han optado por conectar las APIS de métricas y los registros estructurados de IRIS a la plataforma de monitorización existente en sus organizaciones, para tener una visión más completa de su plataforma operativa.

Si tenéis alguna pregunta sobre vuestro uso actual o planeado de SAM, podéis dirigiros a vuestro contacto local en InterSystems.

0 0
0 35
InterSystems Official
· 27 oct, 2023
Finaliza el soporte a VxFS

InterSystems finalizará el soporte al uso del sistema de archivos VxFS con InterSystems IRIS y lo marcará como deprecated (depreciado, obsoleto, en desuso) a partir del lanzamiento de InterSystems IRIS 2023.3. InterSystems seguirá dando soporte a los clientes existentes que utilicen la tecnología, pero no lo recomienda para nuevas implementaciones.

1 0
0 28
InterSystems Official
· 26 oct, 2023
Finaliza el soporte a CentOS

CentOS dejará de ser una plataforma de desarrollo soportada desde la versión 2023.3 de InterSystems IRIS.

CentOS ha sido una plataforma de desarrollo soportada para que todos los desarrolladores tengan un equivalente de uso gratuito a Red Hat Enterprise Linux (RHEL) al programar con IRIS. Como seguramente sabréis, Red Hat ha realizado cambios significativos en CentOS, que ha pasado a ser la "fuente" de RHEL. Esto significa que tiene errores y funcionalidades aún no incluidas en RHEL, lo que puede provocar problemas de desarrollo en dicha plataforma.

Animamos a los desarrolladores que usen CentOS a aprovechar el programa gratuito para desarrolladores y conseguir licencias de desarrollo gratuitas en RHEL.

IRIS 2023.2 (y anteriores) continúa siendo soportada en CentOS.

1 0
0 31

InterSystems ha decidido detener nuevos desarrollos de InterSystems Cloud Manager y etiquetarlo como discontinuado a partir de la versión 2023.3 de InterSystems IRIS. InterSystems seguirá dando soporte a los clientes existentes que utiliicen la tecnología, pero no lo recomienda para nuevas implementaciones.

0 0
0 39

InterSystems ha decidido detener nuevos desarrollos de InterSystems IRIS Natural Language Processing (NLP), antes conocido como iKnow y etiquetarlo como discontinuado a partir de la versión 2023.3 de InterSystems IRIS. InterSystems seguirá dando soporte a los clientes existentes que utilicen la tecnología, pero no recomienda empezar nuevos proyectos de desarrollo fuera de los casos de uso principales de exploración de texto para los que fue diseñado originalmente.

0 0
0 38

18 de septiembre de 2023

InterSystems ha corregido dos defectos relativos a la conectividad. Estos defectos y sus correcciones son independientes uno de otro.

Esta alerta aborda ambos problemas porque hay point releases que contienen ambas correcciones.

Los dos defectos solo afectan a las versiones 2019.1.4 y 2020.1.4 de:

  • InterSystems IRIS®
  • InterSystems IRIS for Health
  • HealthShare® Health Connect

0 0
0 31

1 de agosto de 2023

InterSystems ha corregido dos defectos.

El primer defecto puede provocar que un servidor de aplicaciones ECP se bloquee. Este defecto solo es relevante para procesadores ARM e IBM Power; está presente en la versión 2022.1.2 y 2022.1.3 de InterSystems IRIS®, InterSystems IRIS for Health™ y HealthShare® Health Connect. La corrección de identifica como DP-423661. El defecto está controlado en todas las versiones futuras.

El segundo defecto puede, en circunstancias excepcionales, provocar que el dejournaling se bloquee. Este defecto está presente en las versiones 2020.4, 2021.x, 2022.x y 2023.1 de InterSystems IRIS®, InterSystems IRIS for Health™ y HealthShare® Health Connect. La corrección de identifica como DP-423505. El defecto esta controlado en todas las versiones futuras y ya está corregido en la versión 2023.1.1.

0 0
0 26

13 de junio de 2023

InterSystems ha corregido un defecto que causaba un aumento en el uso de la memoria de proceso.

Específicamente, el aumento de consumo de la partición de memoria local de proceso occurre cuando se ejecutan $Order, $Query, o Merge en variables locales. Aunque esto no tiene un impacto perjudicial en la mayoría de los entornos en ejecución, entornos que soportan un gran número de procesos o limitan la Memoria Máxima Por Proceso de forma muy ajustada, podrían verse afectados. Algunos procesos podrían sufrir errores de tipo <STORE>.

1 0
0 65

InterSystems anuncia la finalización del mantenimiento de Zen Reports, empezando en InterSystems IRIS e IRIS for Health 2025.1. Esto se deriva del aviso de discontinuación realizado cuando InterSystems IRIS fue presentado en 2018 y de la posterior inclusión de InterSystems Reports en 2020 para ofrecer un reemplazo a la funcionalidad de informes. Este es un repaso a la cronología:

0 0
0 43

InterSystems está comprometida con ofrecer a los desarrolladores una experiencia de alta calidad, incluyendo un excelente IDE (Integrated Developer Experience). Durante los últimos años hemos estado evolucionando nuestras herramientas de Objecscript en Visual Studio Code en paralelo a nuestro IDE de toda la vida, InterSystems Studio. Ha habido más de 46 000 descargas del plugin VSCode-ObjectScript, y los desarrolladores comentan que ofrece una excelente experiencia para desarrollar, ahora superior a InterSystems Studio.

0 0
0 114

27 de abril de 2023

InterSystems ha corregido un defecto que puede provocar la corrupción de las bases de datos y los ficheros journal en sistemas AIX con IBM POWER8 o procesadores POWER posteriores. Este defecto solo se puede desencadenar cuando se utiliza la encriptación de base de datos o de journal.

Para que se desencadene este defecto, se requieren las siguientes condiciones:

Si el entorno cumple todas estas condiciones, entonces la key utilizada para la encriptación de la base de datos o journal, puede corromperse.

0 0
0 51
InterSystems Official
· 19 abr, 2023
Alerta: Inestabilidad en cliente ECP

10 de abril de 2023

InterSystems ha corregido un defecto que puede resultar en inestabilidad del cliente de Enterprise Cache Protocol (ECP) en condiciones excepcionales.

El defecto existe en los siguientes productos y en cualquier distribución de InterSystems basada en ellos.

Versiones impactadas: 2022.1.x, 2022.2 y 2022.3:

InterSystems IRIS®

InterSystems IRIS for Health

HealthShare® Health Connect

Versión impactada: 2022.2 (solo para clientes usando ECP):

InterSystems HealthShare®

0 0
0 24

15 de febrero de 2023

InterSystems ha corregido un problema que puede hacer que InterSystems IRIS® y Caché no aprovechen las páginas grandes (large pages) para memoria compartida en Windows, aunque estos productos informen de que las páginas grandes están asignadas. Esto puede afectar al rendimiento del sistema.

El problema proviene de un cambio en Windows 10 que requiere una modificación de InterSystems IRIS® y Caché. Hay que tener en cuenta que este problema también afecta a todos los productos de InterSystems que están basados en InterSystems IRIS® o Caché. El problema ocurre en las siguientes versiones de Windows:

0 0
0 77

En InterSystems creemos en la divulgación responsable de vulnerabilidades de seguridad descubiertas recientemente. Ofrecemos información oportuna a nuestros clientes, a la vez que la mantenemos fuera del alcance de las personas que puedan hacer un mal uso. También entendemos que cada cliente puede tener diferentes necesidades relacionadas con la resolución de problemas de seguridad.

Desde el inicio de 2023, hemos realizado dos cambios significativos en nuestro enfoque sobre la corrección de las vulnerabilidades de seguridad que me gustaría destacar:

  1. Los parches de vulnerabilidad de seguridad se incluirán en cada actualización
  2. Notificación a los clientes mejorada

1 0
0 55

Docker 20.10.14 (lanzado el 23 de marzo de 2022) cambia las funcionalidades que Linux da a los contenedores de una manera que es incompatible con el Linux capability checker en los contenedores de InterSystems IRIS 2021.1 (y posteriores).

Los usuarios ejecutando Docker 20.10.14 en Linux encontrarán que los contenedores de IRIS 2021.1+ fallarán al iniciarse y los logs reportarán de forma incorrecta que las funcionalidades requeridas de Linux no se encuentran. Por ejemplo:

0 0
0 73