Log in or sign up to continue

Respuestas

Por supuesto! Siempre puedes usar JDBC o ODBC. Dame más datos para poder ayudarte.

Buenas tardes David,

Necesito hacer un pipeline entre Intersystem y MySQL por PHP.

Es posible hacer esto?

Muchas Gracias por tu ayuda

Saludos

A qué te refieres con pipeline por PHP????

si quieres conectar una BD MySQL con Caché se puede hacer de varias formas. Por ejemplo mediante tablas vinculadas. De esta forma tablas de una BD externa se ven como tablas propias de Caché.

Pero sigo sin saber muy bien que necesitas 

Buen día David, gracias por tu respuesta!!

Básicamente, necesito consultar tablas de Avaya Aura Contact Center (InterSystem Cache ) y todos esos datos pasarlos a otra base de datos (MySQL) via PHP. 

Saludos

Roman 

Lo de pasar los datos “vía PHP” es lo que me suena muy raro. Si quieres migrar los datos de una BD a la otra se me ocurren mil mejores formas que con PHP. Si lo que necesitas es conectarte a Caché para recuperar información a una pantalla de PHP y luego moverla a MySQL. El problema se reduce a conectar PHP a Caché. Mírate este proyecto de código abierto: https://github.com/chrisemunt/mg_php

Buen día David, 

Siguiendo los pasos del readme del proyecto: 
1) instalar gcc (listo)
2) descargar el codigo desde GitHub (listo)
3) nos paramos en el directorio src del proyecto, y ejecutamos phpize (listo)
4) parados en el mismo directorio ejecutamos  ./configure (listo)
5) luego ejecutamos make (para preparar la instalación), y es aca donde tenemos varios errores que no nos dejan seguir. Me imagino que por algunas dependencias que faltan, que no sabría cuales porque tampoco están detalladas como requisitos.

Me podrías orientar en este punto?

Adjunto captura de pantalla con error

Desde ya muchas gracias

Hola Román,

La verdad es que no sabría ayudarte en esto. Normalmente si tienes un problema con un proyecto de GitHub abres un caso en ese proyecto para que el autor te ayude. En este caso sería aquí:  https://github.com/chrisemunt/mg_php/issues

Por otro lado, entiendo que todas estas herramientas no están estandarizadas en repositorios de linux, se las debe instalar manualmente.