InterSystems Official
David Reche · Jul 20

Ya está disponible IAM 2.8.1

La versión 2.8.1 de InterSystems API Manager (IAM) ya está disponible de forma general (GA). Además de las mejoras en el rendimiento y la corrección de errores, esta versión añade nuevas funcionalidades importantes, como:

  • Core
    • Consumer Groups - Permite agrupar consumidores para crear niveles de servicio
    • Event Hooks - Permite que IAM llame a un web hook cuando ocurren ciertos eventos. Por ejemplo, envíe un mensaje de PagerDuty si falla un endpoint.
    • Improvements to Hybrid Mode - Comprobación de versión relajada; el plano de control puede seguir funcionando si la base de datos está inactiva
  • Nuevos Plug-ins
    • JQ - Aplica transformaciones a mensajes JSON.
    • OPA - Open Policy Agent es un estándar de la industria para describir las políticas de acceso y seguridad de manera estándar
    • Mocking - Acelera las prácticas de desarrollo API-first
  • Admin Console
    • Filtering & Sorting
    • TLS 1.3 for Development Portal

IAM es un API gateway entre tus servidores de InterSystems IRIS y tus aplicaciones, permitiendo monitorizar, controlar y regular tráfico web a escala. IAM está disponible como un extra gratuito de la licencia de InterSystems IRIS.

IAM 2.8.1 se puede descargar del área de Componentes de la Página de Distribución de Software del Centro de Soporte Internacional (WRC).

Sigue la Guía de Instalación para saber cómo descargar, instalar y empezar a utilizar IAM. La documentación completa de IAM 2.8.1 ofrece más información sobre IAM y su uso con InterSystems IRIS. Nuestro partner Kong ofrece más documentación sobre IAM en la documentación de Kong Gateway (Enterprise) 2.8.x.

IAM solo está disponible en OCI (Open Container Initiative), es decir, en formato contenedor Docker. Las imágenes para contenedor están disponibles para motores del run-time compatibles con Linux x86-64 y Linux ARM64, como se detalla en el Documento de Plataformas Soportadas.

 

El número de compilación de esta versión es IAM 2.8.1.0-3. 

Esta versión está basada en la versión 2.8.1 de Kong Gateway (Enterprise).

1
0 18
Debate (0)2
Inicie sesión o regístrese para continuar