Alerta: Violación de acceso con Shadowing

Solapas principales

InterSystems ha corregido un defecto que puede ocasionar que el servicio de shadowing falle con una violación de acceso. En algunos casos, el defecto puede causar corrupción de memoria, produciendo un comportamiento impredecible. 

Nota: El defecto no afecta al mirroring.

El defecto afecta a:

  • InterSystems IRIS 2019.1.1 y 2019.3
  • IRIS for Health 2019.1.1 y 2019.3
  • HealthShare Health Connect 2019.1.1
  • HealthShare Health Connect (HSAP) 15.032 on 2018.1.3
  • Caché y Ensemble 2018.1.3

En InterSystems IRIS e IRIS for Health, se incluye la funcionalidad de shadowing, pero no debería ser usada; InterSystems recomienda utilizar mirroring, que no está afectado por este defecto. 

El defecto ocurre solo en servidores shadow (también conocidos como shadow destinations); las fuentes shadow no están afectadas. Todos los servidores shadow son vulnerables a este defecto.

La corrección de este defecto se identifica como HYY2375, y se incluirá en todas las versiones futuras de InterSystems IRIS, Caché y Ensemble; está disponible bajo petición (distribución ad hoc) en el Centro de Soporte Internacional (WRC).