Version of Eclipse for Atelier

Solapas principales

Will the Atelier plug-in work with newer versions of Eclipse?

 

Photon is getting a bit old and I'd like to use the latest version.

One additional question; Does Atelier work with JDK 11?

Dave

Respuestas

Atelier still only works with Eclipse Photon. Eclipse changed some underlying mechanisms with newer versions of their product, and InterSystems has not had the dev cycles to find the root cause + make the necessary corrections to the Atelier plugin.

Atelier is technically only supported with Java 8. I have heard about other versions of Java working just fine, but these have not been tested by InterSystems' QD team. If you have other Java-based apps that you would like to be using a later version of Java with, you can have multiple Java installs and configure Eclipse to look at Java 8. You should be able to Google to find out more to about how to configure that for your OS.