$System.OBJ.Upgrade not updating class dictionary

Solapas principales

I am currently working on an Upgrade to HealthShare 2019.1.1. As described in the steps once the upgrade was complete to run $system.OBJ.Upgrade(). When I run $system.OBJ.Upgrade() , it is not finding any classes to update. However I am getting an Error 5116 on one of my Productions...

Class dictionary version for '%1' is out of date, please run upgrade utility $system.OBJ.Upgrade()

 

so if I am running $system.OBJ.upgrade() why isn't it updating this production as it should?

Thanks

Scott Roth

  • + 1
  • 1
  • 104
  • 6

Respuestas

I have tried UpgradeAll() also without any luck. Is it possible to just Show and Set qualifiers on just one production to tell me whats wrong with it? I can't open the production class in studio either.

$system.UpgradeAll("",.ERRLOG may give you a hint on problems.

Studio sticks with dictionary version. If there is a mismatch Studio refuses. And Mgmt Portal only shows Class documentation.

I'm not so familiar with Healthshare: Is there eventually some Read/Only DB involved that blocks Update ?
I think of class... EXTENDS (read/only class), ENSLIB ???

Here is an interesting outcome from playing around. Before I could not open the osuwmc.TestClin in either studio or the Management portal after an upgrade/compile to 2019.1.1.

So I was wondering if I should just look at the file. So I exported it from studio, looked at it on my local desktop, then imported it locally from my desktop. I was able to compile it through studio without issues, and Management Portal was able to see the production as well.

Weird.....